aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-01-21 23:56:40 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-01-22 01:05:30 +0600
commit4ad90e2d523f53fbfb3cbab7bc97aa01ce50ae63 (patch)
treebec197fc737e58ffa8e1cafd36991990e7aa9895 /Makefile.am
parent7c0e4dfb568ebe62b2ac1e2a95647955371434bf (diff)
downloadmpd-4ad90e2d523f53fbfb3cbab7bc97aa01ce50ae63.tar.gz
mpd-4ad90e2d523f53fbfb3cbab7bc97aa01ce50ae63.tar.xz
mpd-4ad90e2d523f53fbfb3cbab7bc97aa01ce50ae63.zip
FileSystem: extract DirectoryReader, improve the rest
- DirectoryReader is extracted to separate header - FileSystem.cxx/FileSystem.hxx/DirectoryReader.hxx moved to fs/ subdir - Functions return true on success, instead of 0 (where applicable) - ReadLink return result instead of out parameter - UnlinkFile is renamed to RemoveFile - CheckExists/CheckIsRegular/CheckIsDirectory are renamed to PathExists/FileExists/DirectoryExists
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 92e6e05bb..26b678526 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,6 +151,8 @@ src_mpd_SOURCES = \
src/thread/PosixCond.hxx \
src/thread/WindowsCond.hxx \
src/thread/GLibCond.hxx \
+ src/fs/FileSystem.cxx src/fs/FileSystem.hxx \
+ src/fs/DirectoryReader.hxx \
src/glib_socket.h \
src/clock.c src/clock.h \
src/notify.cxx src/notify.hxx \
@@ -289,7 +291,6 @@ src_mpd_SOURCES = \
src/Volume.cxx src/Volume.hxx \
src/SongFilter.cxx src/SongFilter.hxx \
src/PlaylistFile.cxx src/PlaylistFile.hxx \
- src/FileSystem.cxx src/FileSystem.hxx \
src/timer.c
#