aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-03 01:02:53 +0200
committerMax Kellermann <max@duempel.org>2009-07-03 01:02:53 +0200
commit48f3e13beccec63de5322e2cc0c241527efeabef (patch)
tree8ec13aed180ef6e423e783d7a1ac803098f4d79d /Makefile.am
parenta923080d9b0d4866025404bcaf97111707d6fe23 (diff)
downloadmpd-48f3e13beccec63de5322e2cc0c241527efeabef.tar.gz
mpd-48f3e13beccec63de5322e2cc0c241527efeabef.tar.xz
mpd-48f3e13beccec63de5322e2cc0c241527efeabef.zip
filter: added new plugin API for filters
The filter API allows us to implement software volume as a pluggable filter, and we will be able to integrate libraries like SoX.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e51334e6e..0a5a1d505 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,6 +42,9 @@ mpd_headers = \
src/output_state.h \
src/output_print.h \
src/output_command.h \
+ src/filter_internal.h \
+ src/filter_plugin.h \
+ src/filter_registry.h \
src/buffer2array.h \
src/command.h \
src/idle.h \
@@ -188,6 +191,9 @@ src_mpd_SOURCES = \
src/database.c \
src/dirvec.c \
src/fifo_buffer.c \
+ src/filter_plugin.c \
+ src/filter_registry.c \
+ src/filter/null_filter_plugin.c \
src/update.c \
src/client.c \
src/listen.c \