aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-05-29 23:15:41 +0200
committerMax Kellermann <max@duempel.org>2012-05-29 23:15:41 +0200
commit457d98c8605c3406a2f83f8f099abe0048968efb (patch)
tree16c57c4ab55a219384eaed1a16fb902403a4994e /Makefile.am
parent3c3f1b7ff27c13b817a7a94ef7605e06c93e4ff2 (diff)
downloadmpd-457d98c8605c3406a2f83f8f099abe0048968efb.tar.gz
mpd-457d98c8605c3406a2f83f8f099abe0048968efb.tar.xz
mpd-457d98c8605c3406a2f83f8f099abe0048968efb.zip
output/raop: delete the RAOP plugin
This plugin is horrible code, I mean it. Last year, I tried hard to fix it, but I figured would take less time to do a full rewrite. Given that I don't even have any device that supports RAOP, I can't do that properly. After 16 months, nobody volunteered for fixing it. Hereby, I delete it, because having no RAOP plugin is better than having this mess. Sorry.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 0 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index c0cbbd99b..9b54b9990 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -841,15 +841,6 @@ if HAVE_OSX
liboutput_plugins_a_SOURCES += src/output/osx_output_plugin.c
endif
-if ENABLE_RAOP_OUTPUT
-liboutput_plugins_a_SOURCES += \
- src/ntp_server.c src/ntp_server.h \
- src/rtsp_client.c src/rtsp_client.h \
- src/output/raop_output_plugin.c
-libmixer_plugins_a_SOURCES += src/mixer/raop_mixer_plugin.c
-OUTPUT_LIBS += $(OPENSSL_LIBS)
-endif
-
if HAVE_PULSE
liboutput_plugins_a_SOURCES += \
src/output/pulse_output_plugin.c src/output/pulse_output_plugin.h
@@ -992,7 +983,6 @@ noinst_PROGRAMS = \
test/dump_playlist \
test/run_decoder \
test/read_tags \
- test/run_ntp_server \
test/run_filter \
test/run_output \
test/run_convert \
@@ -1131,14 +1121,6 @@ test_dump_rva2_SOURCES = test/dump_rva2.c \
src/tag_rva2.c
endif
-test_run_ntp_server_LDADD = \
- $(GLIB_LIBS)
-test_run_ntp_server_SOURCES = test/run_ntp_server.c \
- test/signals.c test/signals.h \
- src/io_thread.c src/io_thread.h \
- src/udp_server.c src/udp_server.h \
- src/ntp_server.c src/ntp_server.h
-
test_run_filter_LDADD = \
$(FILTER_LIBS) \
$(GLIB_LIBS)