aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-12-16 20:04:36 +0100
committerMax Kellermann <max@duempel.org>2009-12-16 22:19:01 +0100
commit3679d5bd7ac3a64d342b204c821dc6ccb891ad67 (patch)
tree89aba58eb94ad9d30e24ed6866fa535218e27136 /Makefile.am
parentc128f2dd7e289f32e1ecaaaf467ac0796715d1f5 (diff)
downloadmpd-3679d5bd7ac3a64d342b204c821dc6ccb891ad67.tar.gz
mpd-3679d5bd7ac3a64d342b204c821dc6ccb891ad67.tar.xz
mpd-3679d5bd7ac3a64d342b204c821dc6ccb891ad67.zip
playlist: added CUE playlist plugin
This plugin is the groundwork for MPD's future generic CUE sheet support. That's not complete yet, e.g. there is no way for a playlist plugin to address an arbitrary position within a music file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d74ab36b..ed391b5a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,6 +160,7 @@ mpd_headers = \
src/playlist/xspf_playlist_plugin.h \
src/playlist/asx_playlist_plugin.h \
src/playlist/lastfm_playlist_plugin.h \
+ src/playlist/cue_playlist_plugin.h \
src/poison.h \
src/riff.h \
src/aiff.h \
@@ -707,6 +708,10 @@ if ENABLE_LASTFM
PLAYLIST_SRC += src/playlist/lastfm_playlist_plugin.c
endif
+if HAVE_CUE
+PLAYLIST_SRC += src/playlist/cue_playlist_plugin.c
+endif
+
#
# Filter plugins
@@ -782,9 +787,11 @@ test_run_input_SOURCES = test/run_input.c \
$(INPUT_SRC)
test_dump_playlist_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(CUE_CFLAGS) \
$(ARCHIVE_CFLAGS) \
$(INPUT_CFLAGS)
test_dump_playlist_LDADD = $(MPD_LIBS) \
+ $(CUE_LIBS) \
$(ARCHIVE_LIBS) \
$(INPUT_LIBS) \
$(GLIB_LIBS)
@@ -798,6 +805,10 @@ test_dump_playlist_SOURCES = test/dump_playlist.c \
$(INPUT_SRC) \
$(PLAYLIST_SRC)
+if HAVE_CUE
+test_dump_playlist_SOURCES += src/cue/cue_tag.c
+endif
+
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
$(TAG_CFLAGS) \
$(ARCHIVE_CFLAGS) \