aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-04-17 21:46:16 +0200
committerMax Kellermann <max@duempel.org>2013-04-17 21:46:16 +0200
commit2df2a989af3296b1d6c7bc829ad3139e290ee474 (patch)
treef2c354c257b17c53caaad79bce050c4cea1a6c86 /Makefile.am
parent4a800b311f5dfde74956edb29dee99998ba1ced1 (diff)
downloadmpd-2df2a989af3296b1d6c7bc829ad3139e290ee474.tar.gz
mpd-2df2a989af3296b1d6c7bc829ad3139e290ee474.tar.xz
mpd-2df2a989af3296b1d6c7bc829ad3139e290ee474.zip
input/soup: plugin removed
This plugin is cumbersome to support, now that MPD is migrating away from GLib and the GLib event loop. It has no practical advantages over the CURL plugin. Soup requires the bloated GType library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 766506f94..cc7a9c294 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -697,7 +697,6 @@ libinput_a_SOURCES = \
libinput_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(CURL_CFLAGS) \
- $(SOUP_CFLAGS) \
$(CDIO_PARANOIA_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(DESPOTIFY_CFLAGS) \
@@ -706,7 +705,6 @@ libinput_a_CPPFLAGS = $(AM_CPPFLAGS) \
INPUT_LIBS = \
libinput.a \
$(CURL_LIBS) \
- $(SOUP_LIBS) \
$(CDIO_PARANOIA_LIBS) \
$(FFMPEG_LIBS) \
$(DESPOTIFY_LIBS) \
@@ -718,11 +716,6 @@ libinput_a_SOURCES += \
src/IcyMetaDataParser.cxx src/IcyMetaDataParser.hxx
endif
-if ENABLE_SOUP
-libinput_a_SOURCES += \
- src/input/SoupInputPlugin.cxx src/input/SoupInputPlugin.hxx
-endif
-
if ENABLE_CDIO_PARANOIA
libinput_a_SOURCES += \
src/input/CdioParanoiaInputPlugin.cxx \