aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-04 20:50:00 +0100
committerMax Kellermann <max@duempel.org>2013-01-04 22:12:33 +0100
commit05c91082e3de0b0078c26ddb9da68fd00da8c90e (patch)
tree7f1ef3988b787ab3e1e07e0147fabf94963495a5 /Makefile.am
parent7267558ba1cba9338c78b41d11e2eadef6bb515b (diff)
downloadmpd-05c91082e3de0b0078c26ddb9da68fd00da8c90e.tar.gz
mpd-05c91082e3de0b0078c26ddb9da68fd00da8c90e.tar.xz
mpd-05c91082e3de0b0078c26ddb9da68fd00da8c90e.zip
playlist: convert to C++
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e76eb54f..e0ef76586 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,9 +115,9 @@ mpd_headers = \
src/output/httpd_internal.h \
src/page.h \
src/player_control.h \
- src/playlist.h \
+ src/Playlist.hxx \
src/playlist_error.h \
- src/playlist_internal.h \
+ src/PlaylistInternal.hxx \
src/playlist_plugin.h \
src/playlist_list.h \
src/playlist/extm3u_playlist_plugin.h \
@@ -132,7 +132,6 @@ mpd_headers = \
src/poison.h \
src/riff.h \
src/aiff.h \
- src/queue.h \
src/refcount.h \
src/replay_gain_config.h \
src/replay_gain_info.h \
@@ -267,9 +266,9 @@ src_mpd_SOURCES = \
src/Permission.cxx src/Permission.hxx \
src/PlayerThread.cxx src/PlayerThread.hxx \
src/PlayerControl.cxx \
- src/playlist.c \
- src/playlist_global.c \
- src/playlist_control.c \
+ src/Playlist.cxx \
+ src/PlaylistGlobal.cxx \
+ src/PlaylistControl.cxx \
src/PlaylistEdit.cxx \
src/PlaylistPrint.cxx src/PlaylistPrint.hxx \
src/PlaylistSave.cxx src/PlaylistSave.hxx \
@@ -281,7 +280,7 @@ src_mpd_SOURCES = \
src/PlaylistVector.cxx src/PlaylistVector.hxx \
src/PlaylistInfo.hxx \
src/PlaylistDatabase.cxx \
- src/queue.c \
+ src/Queue.cxx src/Queue.hxx \
src/QueuePrint.cxx src/QueuePrint.hxx \
src/QueueSave.cxx src/QueueSave.hxx \
src/replay_gain_config.c \
@@ -1339,7 +1338,7 @@ test_test_pcm_LDADD = \
$(GLIB_LIBS)
test_TestQueuePriority_SOURCES = \
- src/queue.c \
+ src/Queue.cxx \
test/TestQueuePriority.cxx
test_TestQueuePriority_LDADD = \
$(GLIB_LIBS)