aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-06 22:00:50 +0200
committerMax Kellermann <max@duempel.org>2009-07-06 22:00:50 +0200
commit0275690b5cd133f992e9e34d6c76eb134aef26bd (patch)
tree3ce67839d522420ff7b99224cdc8892c86395036 /Makefile.am
parentda8095db546544bb9fe3a455ef5742bfef9c2f4f (diff)
downloadmpd-0275690b5cd133f992e9e34d6c76eb134aef26bd.tar.gz
mpd-0275690b5cd133f992e9e34d6c76eb134aef26bd.tar.xz
mpd-0275690b5cd133f992e9e34d6c76eb134aef26bd.zip
output: use the software mixer plugin
Do all the software volume stuff inside each output thread, not in the player thread. This allows one software mixer per output device, and also allows the user to configure the mixer type (hardware or software) for each audio output. This moves the global "mixer_type" setting into the "audio_output" section, deprecating the "mixer_enabled" flag.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c37a6cca8..d89aeb694 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -740,6 +740,7 @@ test_run_output_SOURCES = test/run_output.c \
$(ENCODER_SRC) \
src/mixer_api.c \
src/mixer_control.c \
+ src/mixer_type.c \
$(MIXER_SRC) \
src/filter_plugin.c src/filter/chain_filter_plugin.c \
src/filter/convert_filter_plugin.c \