aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-11 10:50:59 +0100
committerMax Kellermann <max@duempel.org>2013-01-11 11:11:07 +0100
commit0226440a2d915e34139413803b3c9fbb261dd9c1 (patch)
tree98efb491b9b3dfc26b37593af35f49edb98d588a /Makefile.am
parent9d770d6084cb90b99ab129ff0b9e1ef57aab9a83 (diff)
downloadmpd-0226440a2d915e34139413803b3c9fbb261dd9c1.tar.gz
mpd-0226440a2d915e34139413803b3c9fbb261dd9c1.tar.xz
mpd-0226440a2d915e34139413803b3c9fbb261dd9c1.zip
thread/{Mutex,Cond}: new backend for WIN32
Use CRITICAL_SECTION and CONDITION_VARIABLE. This requires Windows Vista or newer. It fixes problems with GLib threading objects that were implicitly created by static constructors before g_thread_init().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe922a6af..170e74dc0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -158,9 +158,11 @@ src_mpd_SOURCES = \
$(MIXER_API_SRC) \
src/thread/Mutex.hxx \
src/thread/PosixMutex.hxx \
+ src/thread/CriticalSection.hxx \
src/thread/GLibMutex.hxx \
src/thread/Cond.hxx \
src/thread/PosixCond.hxx \
+ src/thread/WindowsCond.hxx \
src/thread/GLibCond.hxx \
src/glib_socket.h \
src/clock.c src/clock.h \