aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 55454148..b97df6d2 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# Copyright (C) 1998-2006 by the Free Software Foundation, Inc.
+# Copyright (C) 1998-2007 by the Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
@@ -101,7 +101,14 @@ else:
except distutils.errors.DistutilsPlatformError:
res = "no"
else:
- res = "yes"
+ # some RedHat packages put distutils in python, but the C headers
+ # are in python-devel so check for headers too.
+ import os.path
+ pdothpath = distutils.sysconfig.get_config_var('CONFINCLUDEPY')
+ if os.path.isfile(os.path.join(pdothpath, "Python.h")):
+ res = "yes"
+ else:
+ res = "no"
fp = open("conftest.out", "w")
fp.write("%s\n" % res)
fp.close()
@@ -117,7 +124,8 @@ then
***** Distutils is not available or is incomplete for $PYTHON
***** If you installed Python from RPM (or other package manager)
***** be sure to install the -devel package, or install Python
-***** from source. See README.LINUX for details])
+***** from source. See sec. 15.1 of the Installation Manual for
+***** details])
fi
AC_MSG_RESULT($havedistutils)