aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Sapiro <mark@msapiro.net>2014-04-25 00:34:08 -0700
committerMark Sapiro <mark@msapiro.net>2014-04-25 00:34:08 -0700
commitd2f3fd4357520fce37fcc3edc5b6d8de7f5af879 (patch)
treed490f0c8bb887599d9da557af9e202a122d4deed /configure.in
parent5c6b9208dd8c654fa564785d09173680926bd3ed (diff)
downloadmailman2-d2f3fd4357520fce37fcc3edc5b6d8de7f5af879.tar.gz
mailman2-d2f3fd4357520fce37fcc3edc5b6d8de7f5af879.tar.xz
mailman2-d2f3fd4357520fce37fcc3edc5b6d8de7f5af879.zip
Made configure check for dnspython.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ee55b96..f7bb7919 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,34 @@ then
fi
AC_MSG_RESULT($version)
+# See if dnspython is installed.
+AC_MSG_CHECKING(dnspython)
+changequote(,)
+cat > conftest.py <<EOF
+try:
+ import dns.resolver
+ res = 'ok'
+except ImportError:
+ res = 'no'
+fp = open("conftest.out", "w")
+fp.write("%s\n" % res)
+fp.close()
+EOF
+changequote([, ])
+$PYTHON conftest.py
+havednspython=`cat conftest.out`
+rm -f conftest.out conftest.py
+if test "$havednspython" = "no"
+then
+ AC_MSG_ERROR([
+
+***** dnspython not found. It is required for the new
+***** dmarc_moderation_action featurer. Get it from
+***** <http://www.dnspython.org/> or
+***** <https://pypi.python.org/pypi/dnspython/>])
+fi
+AC_MSG_RESULT($havednspython)
+
# Check the email package version.
AC_MSG_CHECKING(Python's email package)
changequote(,)