aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorYasuhito FUTATSUKI at POEM <futatuki@poem.co.jp>2018-01-12 21:44:15 +0900
committerYasuhito FUTATSUKI at POEM <futatuki@poem.co.jp>2018-01-12 21:44:15 +0900
commit16572087609fc9c9b9f55c26c9c55985fbcad804 (patch)
treed0af2f969c000db00909f66f9501634c43c8df26 /configure.in
parentadb3d9035314760b62d92bda4a41991b7420360f (diff)
parentc4a7c961798353841a75c862a6fe9e22529db45d (diff)
downloadmailman2-16572087609fc9c9b9f55c26c9c55985fbcad804.tar.gz
mailman2-16572087609fc9c9b9f55c26c9c55985fbcad804.tar.xz
mailman2-16572087609fc9c9b9f55c26c9c55985fbcad804.zip
sync with lp:mailman/2.1 Rev 1734
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f7bb7919..e4956674 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# Copyright (C) 1998-2008 by the Free Software Foundation, Inc.
+# Copyright (C) 1998-2018 by the Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
@@ -23,6 +23,10 @@ AC_INIT(src/common.h)
# /usr/local/mailman is the default installation directory
AC_PREFIX_DEFAULT(/usr/local/mailman)
+CONFIGURE_OPTS=`echo $@`
+AC_SUBST(CONFIGURE_OPTS)
+BUILD_DATE=`date`
+AC_SUBST(BUILD_DATE)
# Check for Python! Better be found on $PATH
AC_MSG_CHECKING(for --with-python)
@@ -135,6 +139,17 @@ $PYTHON conftest.py
needemailpkg=`cat conftest.out`
rm -f conftest.out conftest.py
+cat > getver.py <<EOF
+from Mailman.Version import VERSION
+fp = open("getver.out", "w")
+fp.write("%s\n" % VERSION)
+fp.close()
+EOF
+$PYTHON getver.py
+MM_VERSION=`cat getver.out`
+rm -f getver.out getver.py
+AC_SUBST(MM_VERSION)
+
# Should we rely on Python's own email package or use the pre-packaged version?
AC_SUBST(EMAILPKG)
if test "$needemailpkg" = "ok"
@@ -705,6 +720,7 @@ bin/unshunt \
bin/update \
bin/version \
bin/withlist \
+bin/mailman-config \
bin/b4b5-archfix \
bin/rb-archfix \
contrib/check_perms_grsecurity.py \