summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ebd1831
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python
+# -*- coding: iso-8859-1 -*-
+
+from setuptools import setup
+
+setup(
+ name = 'Wikinfo',
+ version = '0.1',
+ packages = ['wikinfo'],
+ package_data = { },
+
+ author = "Noah Kantrowitz",
+ author_email = "coderanger@yahoo.com",
+ description = "Provides a few useful macros to get data about wiki pages",
+ license = "BSD",
+ keywords = "trac wiki info macro",
+ url = "http://trac-hacks.org/",
+
+ entry_points = {
+ 'trac.plugins': [
+ 'wikinfo.wikinfo = wikinfo.wikinfo'
+ ]
+ }
+)
+