aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e8d60626..3c7f1d62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,14 +174,18 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
-# find lua 5.1
-# (K)Ubuntu uses lua5.1.pc, Mac OS X and other
-# linux distributions use lua.pc
-PKG_HAVE([lua], [lua5.1], no)
-lua_LIB_NAME="lua5.1"
+# find lua 5.2 or 5.11
+# (K)Ubuntu uses lua5.2.pc and lua5.1.pc,
+# Mac OS X and other linux distributions use lua.pc
+PKG_HAVE([lua], [lua5.2], no)
+lua_LIB_NAME="lua5.2"
if [[ x$lua_HAVE = xno ]]; then
- PKG_HAVE([lua], [lua >= 5.1], yes)
- lua_LIB_NAME="lua"
+ PKG_HAVE([lua], [lua5.1], no)
+ lua_LIB_NAME="lua5.1"
+ if [[ x$lua_HAVE = xno ]]; then
+ PKG_HAVE([lua], [lua >= 5.1], yes)
+ lua_LIB_NAME="lua"
+ fi
fi
AC_SUBST(lua_LIB_NAME)