aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7055ae6..898af362 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,6 +166,14 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
+# find lua 5.1
+# (K)Ubuntu uses lua5.1.pc, Mac OS X and other
+# linux distributions use lua.pc
+PKG_HAVE([lua], [lua5.1], no)
+if [[ x$lua_HAVE = xno ]]; then
+ PKG_HAVE([lua], [lua >= 5.1], yes)
+fi
+
# find FFMpeg
# Note: do not use the min/max version parameters with ffmpeg
# otherwise it might fail in ubuntu due to a wrong version number