aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 346f0488..7a0afe58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,11 +244,12 @@ AC_SUBST_DEFINE(HAVE_SWSCALE, $libswscale_HAVE)
# the first swresample header translation was in ffmpeg 2.1 (avutil 52.48.100)
if [[ "$libavutil_VERSION_MAJOR" -gt 52 ]] || ([[ "$libavutil_VERSION_MAJOR" -eq 52 ]] && [[ "$libavutil_VERSION_MINOR" -ge 48 ]]); then
- # find FFMpeg's swresample lib (just if FFMpeg is compiled in GPL mode)
- PKG_HAVE([libswresample], [libswresample], no)
- PKG_VERSION([libswresample], [libswresample])
- AC_SUBST_DEFINE(HAVE_SWRESAMPLE, $libswresample_HAVE)
-
+ # find FFMpeg's swresample lib (just if FFMpeg is compiled in GPL mode)
+ PKG_HAVE([libswresample], [libswresample], no)
+ PKG_VERSION([libswresample], [libswresample])
+ AC_SUBST_DEFINE(HAVE_SWRESAMPLE, $libswresample_HAVE)
+else
+ AC_SUBST_DEFINE(HAVE_SWRESAMPLE, xno)
fi
# find projectM version