aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authors_alexander <s_alexander@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-01-13 20:33:19 +0000
committers_alexander <s_alexander@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-01-13 20:33:19 +0000
commite404ff79067fcde24150f42c2dcb926ec5926fd1 (patch)
treea9a3e2c303f254a12dcd8193ea73643aacb352b4 /configure.ac
parent17a8202decb7e88c729a3046f5e0b57eb2d6e6da (diff)
downloadusdx-e404ff79067fcde24150f42c2dcb926ec5926fd1.tar.gz
usdx-e404ff79067fcde24150f42c2dcb926ec5926fd1.tar.xz
usdx-e404ff79067fcde24150f42c2dcb926ec5926fd1.zip
change lua lib filename for different versions
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2088 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f9f6e11..e0846256 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,9 +170,12 @@ PKG_HAVE([sqlite3], [sqlite3], yes)
# (K)Ubuntu uses lua5.1.pc, Mac OS X and other
# linux distributions use lua.pc
PKG_HAVE([lua], [lua5.1], no)
+lua_LIB_NAME="lua5.1"
if [[ x$lua_HAVE = xno ]]; then
PKG_HAVE([lua], [lua >= 5.1], yes)
+ lua_LIB_NAME="lua"
fi
+AC_SUBST(lua_LIB_NAME)
# find FFMpeg
# Note: do not use the min/max version parameters with ffmpeg