aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authors_alexander <s_alexander@b956fd51-792f-4845-bead-9b4dfca2ff2c>2009-12-05 12:24:56 +0000
committers_alexander <s_alexander@b956fd51-792f-4845-bead-9b4dfca2ff2c>2009-12-05 12:24:56 +0000
commite0d74e92c0c7aa5b4e0fd7ee5fae0bff8e513a27 (patch)
tree9dd3702aa4e70897a0a4a198fc3d76cfc66f2195 /configure.ac
parentfd98aca1ce64242788bf0a2bad1f0af058163fd6 (diff)
downloadusdx-e0d74e92c0c7aa5b4e0fd7ee5fae0bff8e513a27.tar.gz
usdx-e0d74e92c0c7aa5b4e0fd7ee5fae0bff8e513a27.tar.xz
usdx-e0d74e92c0c7aa5b4e0fd7ee5fae0bff8e513a27.zip
added pcre dependency
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@1963 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69e358fc..25537088 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,6 +166,20 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
+# find pcre
+AC_ARG_WITH(pcre,
+ [ --with-pcre=<path> prefix of pcre installation (eg /usr/local)],
+ [
+ CPPFLAGS="$CPPFLAGS -I $withval/include"
+ LDFLAGS="$LDFLAGS -L $withval/lib"
+ ]
+)
+
+AC_CHECK_HEADERS(pcre.h,
+ AC_SEARCH_LIBS([pcre_compile], [pcre]) ,
+ AC_MSG_WARN([*** pcre.h not found -- consider using --with-pcre])
+)
+
# find FFMpeg
# Note: do not use the min/max version parameters with ffmpeg
# otherwise it might fail in ubuntu due to a wrong version number