aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-05-24 18:59:38 +0000
committerk-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-05-24 18:59:38 +0000
commitbe3978a078196c423d1974d87bd3cf07a3dd2d45 (patch)
treee44246df2d7e606e71f93f5c4ea2e24c33947aaf /configure.ac
parent5922a70e798ed9ab8c8abf542794602fb82780c5 (diff)
downloadusdx-be3978a078196c423d1974d87bd3cf07a3dd2d45.tar.gz
usdx-be3978a078196c423d1974d87bd3cf07a3dd2d45.tar.xz
usdx-be3978a078196c423d1974d87bd3cf07a3dd2d45.zip
add configure for libpcre and add path for dlopen on darwin
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2416 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e9214e3..78bd2d4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,6 +230,16 @@ AC_SUBST(USE_PROJECTM_CWRAPPER, $libprojectM_USE_CWRAPPER)
PKG_HAVE([portaudio], [portaudio-2.0], yes)
PKG_VERSION([portaudio], [portaudio-2.0])
AC_SUBST_DEFINE(HAVE_PORTAUDIO, $portaudio_HAVE)
+
+# find pcre
+libpcre_PKG="libpcre"
+PKG_HAVE([libpcre], [$libpcre_PKG], yes)
+PKG_VERSION([libpcre], [$libpcre_PKG])
+AC_SUBST_DEFINE(HAVE_LIBPCRE, $libpcre_HAVE)
+# get libpcre library dir
+PKG_VALUE([libpcre], [LIBDIR], [variable=libdir], [$libpcre_PKG],
+ [library dir (e.g. /usr/lib, /sw/lib, ...)])
+
# find portmixer
PKG_HAVE([portmixer], [portmixer], no)
AC_SUBST_DEFINE(HAVE_PORTMIXER, $portmixer_HAVE)