aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2013-01-29 14:39:10 +0000
committerk-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2013-01-29 14:39:10 +0000
commit86bc4727ec521068dd08195d53e2e03aabab4932 (patch)
treebae682b2344cd72f6b8fd5849fcb0d1a18471a23 /configure.ac
parentc68fcc48207a7b23393a9bc07f72570de8fcef86 (diff)
downloadusdx-86bc4727ec521068dd08195d53e2e03aabab4932.tar.gz
usdx-86bc4727ec521068dd08195d53e2e03aabab4932.tar.xz
usdx-86bc4727ec521068dd08195d53e2e03aabab4932.zip
setting check in PKG_HAVE for lua5.*.pc. fixes configure of this cases.
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2937 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c0cebb94..2c566f53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,20 +177,20 @@ PKG_HAVE([sqlite3], [sqlite3], yes)
# find lua 5.2 or 5.11
# (K)Ubuntu uses lua5.2.pc and lua5.1.pc,
# Mac OS X and other linux distributions use lua.pc
-PKG_HAVE([lua], [lua5.2], no)
+PKG_HAVE([lua], [lua5.2], check)
lua_LIB_NAME="lua5.2"
if [[ x$lua_HAVE = xyes ]]; then
PKG_VERSION([lua], [lua5.2])
else
- PKG_HAVE([lua], [lua5.1], no)
+ PKG_HAVE([lua], [lua5.1], check)
lua_LIB_NAME="lua5.1"
if [[ x$lua_HAVE = xyes ]]; then
PKG_VERSION([lua], [lua5.1])
else
- PKG_HAVE([lua], [lua >= 5.1], yes)
+ PKG_HAVE([lua], [lua >= 5.1], yes)
lua_LIB_NAME="lua"
- PKG_VERSION([lua], [lua])
- fi
+ PKG_VERSION([lua], [lua])
+ fi
fi
AC_SUBST(lua_LIB_NAME)