aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorbrian-ch <brian-ch@b956fd51-792f-4845-bead-9b4dfca2ff2c>2016-02-14 18:13:57 +0000
committerbrian-ch <brian-ch@b956fd51-792f-4845-bead-9b4dfca2ff2c>2016-02-14 18:13:57 +0000
commit4dea02ed19873fbd8ee454a1b1147ad10436ab91 (patch)
tree9c3fe3adb2e83cda6b41cba5fdf74ab8bc2dfafe /configure.ac
parent460102260b2d0dfb02e14d88646f6c669f20e898 (diff)
downloadusdx-4dea02ed19873fbd8ee454a1b1147ad10436ab91.tar.gz
usdx-4dea02ed19873fbd8ee454a1b1147ad10436ab91.tar.xz
usdx-4dea02ed19873fbd8ee454a1b1147ad10436ab91.zip
Only try to include libswresample if it is installed and we have pascal headers for that specific version
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@3194 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6a814555..346f0488 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,10 +242,14 @@ PKG_HAVE([libswscale], [libswscale], no)
PKG_VERSION([libswscale], [libswscale])
AC_SUBST_DEFINE(HAVE_SWSCALE, $libswscale_HAVE)
-# find FFMpeg's swresample lib (just if FFMpeg is compiled in GPL mode)
-PKG_HAVE([libswresample], [libswresample], no)
-PKG_VERSION([libswresample], [libswresample])
-AC_SUBST_DEFINE(HAVE_SWRESAMPLE, $libswresample_HAVE)
+# the first swresample header translation was in ffmpeg 2.1 (avutil 52.48.100)
+if [[ "$libavutil_VERSION_MAJOR" -gt 52 ]] || ([[ "$libavutil_VERSION_MAJOR" -eq 52 ]] && [[ "$libavutil_VERSION_MINOR" -ge 48 ]]); then
+ # find FFMpeg's swresample lib (just if FFMpeg is compiled in GPL mode)
+ PKG_HAVE([libswresample], [libswresample], no)
+ PKG_VERSION([libswresample], [libswresample])
+ AC_SUBST_DEFINE(HAVE_SWRESAMPLE, $libswresample_HAVE)
+
+fi
# find projectM version
libprojectM_PKG="libprojectM >= 0.98"