aboutsummaryrefslogtreecommitdiffstats
path: root/Game/Code/configure.ac
diff options
context:
space:
mode:
authortobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2008-07-17 16:25:45 +0000
committertobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2008-07-17 16:25:45 +0000
commit719a05278d2f151639426ff4cd952036419adac3 (patch)
tree565342075097b959b975db18e8c1297da2f9197f /Game/Code/configure.ac
parent943e5130e1b70a9158fe8462eff3123d27135caa (diff)
downloadusdx-719a05278d2f151639426ff4cd952036419adac3.tar.gz
usdx-719a05278d2f151639426ff4cd952036419adac3.tar.xz
usdx-719a05278d2f151639426ff4cd952036419adac3.zip
Mac OS X version check added
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@1205 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'Game/Code/configure.ac')
-rw-r--r--Game/Code/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/Game/Code/configure.ac b/Game/Code/configure.ac
index 490df1da..3dd1a6c3 100644
--- a/Game/Code/configure.ac
+++ b/Game/Code/configure.ac
@@ -365,6 +365,18 @@ if [[ x$PKG_CONFIG = x ]]; then
!!! Install it and try again.])
fi
+
+# -----------------------------------------
+# check for OS
+# -----------------------------------------
+
+if [[ x$FPC_PLATFORM = xdarwin ]]; then
+ AC_MSG_CHECKING([for Mac OS X version])
+ MACOSX_VERSION=`sw_vers -productVersion`
+ AC_SPLIT_VERSION(MACOSX, $MACOSX_VERSION)
+ AC_MSG_RESULT(@<:@$MACOSX_VERSION@:>@)
+fi
+
# -----------------------------------------
# check for libraries
# -----------------------------------------