aboutsummaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
new file mode 100644
index 0000000..aa2599a
--- /dev/null
+++ b/daemon/Makefile.am
@@ -0,0 +1,20 @@
+if OS_WIN32
+
+if DEBUG
+AM_CFLAGS = -g
+endif
+
+if RELOCATABLE
+AM_CPPFLAGS = -DSYSLOG_CONF_DIR=\".$(sysconfdir)\"
+else
+AM_CPPFLAGS = -DSYSLOG_CONF_DIR=\"$(sysconfdir)\"
+endif
+
+AM_CPPFLAGS += -I. -I../include $(GLIB_CFLAGS)
+
+bin_PROGRAMS = syslogd
+syslogd_SOURCES = conf.c fifo.c listener.c logrotate.c main.c names.c \
+ pathnames.c purger.c syslogd.c writer.c syslogd.h
+syslogd_LDADD = -lws2_32 $(GLIB_LIBS)
+
+endif