aboutsummaryrefslogtreecommitdiffstats
path: root/net-libs/nodejs/nodejs-0.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-0.6.3.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-0.6.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/nodejs/nodejs-0.6.3.ebuild b/net-libs/nodejs/nodejs-0.6.3.ebuild
new file mode 100644
index 0000000..3ab4493
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.6.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils python
+
+# omgwtf
+RESTRICT="test"
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+PYTHON_DEPEND="2"
+
+DEPEND=">=dev-lang/v8-3.5.10.22
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ebegin "Converting python shebangs"
+ python_convert_shebangs -r -q -- 2 tools/
+ eend $? || die
+}
+
+src_configure() {
+ # this is a waf confuserator
+ ./configure --prefix=/usr --shared-v8 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+
+ dodoc ChangeLog README.md AUTHORS || die
+ dodoc -r doc/api/api || die
+}