aboutsummaryrefslogtreecommitdiffstats
path: root/dev-util/mfcuk/mfcuk-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mfcuk/mfcuk-9999.ebuild')
-rw-r--r--dev-util/mfcuk/mfcuk-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/mfcuk/mfcuk-9999.ebuild b/dev-util/mfcuk/mfcuk-9999.ebuild
new file mode 100644
index 0000000..fe45531
--- /dev/null
+++ b/dev-util/mfcuk/mfcuk-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils subversion autotools
+
+DESCRIPTION="MiFare Classic Universal toolKit"
+HOMEPAGE="http://code.google.com/p/mfcuk/"
+ESVN_REPO_URI="http://mfcuk.googlecode.com/svn/trunk/"
+ESVN_PROJECT="mfuck"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+CDEPEND=">=dev-libs/libnfc-1.5.1"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/mfcuk-new-libnfc-version.patch"
+ eautoreconf || die "autoreconf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README ChangeLog AUTHORS NEWS TODO || die
+}