aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python/virtualenvwrapper/virtualenvwrapper-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/virtualenvwrapper/virtualenvwrapper-2.3.ebuild')
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-2.3.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-2.3.ebuild
new file mode 100644
index 0000000..0f5fdba
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Enhancements to virtualenv"
+HOMEPAGE="http://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="http://www.doughellmann.com/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/virtualenv"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ python_copy_sources
+
+ patching() {
+ [[ "${PYTHON_ABI}" != 3.* ]] && return
+ epatch "${FILESDIR}/python-3.patch"
+ }
+ python_execute_function --action-message 'Applying patches with $(python_get_implementation) $(python_get_version)' -s patching
+}
+