aboutsummaryrefslogtreecommitdiffstats
path: root/app-text/landslide/landslide-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/landslide/landslide-1.0.1.ebuild')
-rw-r--r--app-text/landslide/landslide-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/landslide/landslide-1.0.1.ebuild b/app-text/landslide/landslide-1.0.1.ebuild
new file mode 100644
index 0000000..1845e88
--- /dev/null
+++ b/app-text/landslide/landslide-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit distutils python
+
+DESCRIPTION="Landslide generates a slideshow using the slides that power the html5-slides presentation"
+HOMEPAGE="https://github.com/adamzap/landslide"
+SRC_URI="https://github.com/adamzap/landslide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+PYTHON_DEPEND="2"
+
+DEPEND=""
+RDEPEND="dev-python/docutils
+ dev-python/jinja
+ dev-python/markdown
+ dev-python/pygments"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ mv adamzap-landslide-* ${P} || die
+}