aboutsummaryrefslogtreecommitdiffstats
path: root/x11-misc/mimeo/mimeo-0.2.ebuild
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2010-02-07 20:11:57 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2010-02-07 20:11:57 +0100
commit3c4b305871a4e83fc0995dc8701acbe8b0955b5c (patch)
tree9fbc6bca0b5d71d2b556956ab8ca59536aa260ef /x11-misc/mimeo/mimeo-0.2.ebuild
parent98043e09ca0a380c558fc69dc1a27a7c4e2317f3 (diff)
downloadoverlay-3c4b305871a4e83fc0995dc8701acbe8b0955b5c.tar.gz
overlay-3c4b305871a4e83fc0995dc8701acbe8b0955b5c.tar.xz
overlay-3c4b305871a4e83fc0995dc8701acbe8b0955b5c.zip
added mimeo package (easy file opening)
Diffstat (limited to 'x11-misc/mimeo/mimeo-0.2.ebuild')
-rw-r--r--x11-misc/mimeo/mimeo-0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/mimeo/mimeo-0.2.ebuild b/x11-misc/mimeo/mimeo-0.2.ebuild
new file mode 100644
index 0000000..b04556f
--- /dev/null
+++ b/x11-misc/mimeo/mimeo-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python
+
+DESCRIPTION="open files using mimetype associations"
+HOMEPAGE="http://xyne.archlinux.ca/info/mimeo"
+SRC_URI="http://xyne.archlinux.ca/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_install() {
+ insinto $(python_get_sitedir)/${PN}
+ newins mimeo/mimeo mimeo.py
+ doins ${FILESDIR}/__init__.py
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/mimeo
+ doexe ${FILESDIR}/mimeo-2.6
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}