aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b68b8a5e1..95e9eec1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,8 +36,8 @@ dnl
AC_CANONICAL_HOST
-case "$host" in
-*-mingw32* | *-windows*)
+case "$host_os" in
+mingw32* | windows*)
MPD_LIBS="$MPD_LIBS -lws2_32"
;;
esac
@@ -532,8 +532,8 @@ AC_ARG_ENABLE(shout-mp3,
[enable_shout_mp3=yes])
enable_osx=no
-case $host in
- *-darwin*)
+case "$host_os" in
+ darwin*)
AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
MPD_LIBS="$MPD_LIBS -framework AudioUnit -framework CoreServices"
enable_osx=yes ;;