aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-18 23:07:13 +0100
committerMax Kellermann <max@duempel.org>2009-02-18 23:07:13 +0100
commit9f8740a0d617608db146a5d5f492d114861e1b15 (patch)
tree39eecae2dba94856f6a3e8924aed89ad1c2f266f /configure.ac
parentf2717a71390fed6c700b429321a9d230998fab3f (diff)
downloadmpd-9f8740a0d617608db146a5d5f492d114861e1b15.tar.gz
mpd-9f8740a0d617608db146a5d5f492d114861e1b15.tar.xz
mpd-9f8740a0d617608db146a5d5f492d114861e1b15.zip
configure.ac: check ${host_os} instead of ${host}
The configure.ac script does not care about the host architecture, it only cares about the OS. Use ${host_os} instead of ${host} to simplify the matching expressions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b68b8a5e1..95e9eec1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,8 +36,8 @@ dnl
AC_CANONICAL_HOST
-case "$host" in
-*-mingw32* | *-windows*)
+case "$host_os" in
+mingw32* | windows*)
MPD_LIBS="$MPD_LIBS -lws2_32"
;;
esac
@@ -532,8 +532,8 @@ AC_ARG_ENABLE(shout-mp3,
[enable_shout_mp3=yes])
enable_osx=no
-case $host in
- *-darwin*)
+case "$host_os" in
+ darwin*)
AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
MPD_LIBS="$MPD_LIBS -framework AudioUnit -framework CoreServices"
enable_osx=yes ;;