aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 95bc0183b..0bd8f9aba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,6 +272,11 @@ AC_ARG_ENABLE(despotify,
[enable support for despotify (default: disable)]),,
[enable_despotify=no])
+AC_ARG_ENABLE(soundcloud,
+ AS_HELP_STRING([--enable-soundcloud],
+ [enable support for soundcloud (default: disable)]),,
+ [enable_soundcloud=no])
+
AC_ARG_ENABLE(lame-encoder,
AS_HELP_STRING([--enable-lame-encoder],
[enable the LAME mp3 encoder]),,
@@ -702,6 +707,12 @@ if test x$enable_despotify = xyes; then
fi
AM_CONDITIONAL(ENABLE_DESPOTIFY, test x$enable_despotify = xyes)
+dnl --------------------------------- Soundcloud ------------------------------
+if test x$enable_soundcloud = xyes; then
+ AC_DEFINE(ENABLE_SOUNDCLOUD, 1, [Define when soundcloud is enabled])
+fi
+AM_CONDITIONAL(ENABLE_SOUNDCLOUD, test x$enable_soundcloud = xyes)
+
dnl ---------------------------------- cdio ---------------------------------
MPD_AUTO_PKG(cdio_paranoia, CDIO_PARANOIA, [libcdio_paranoia],
[libcdio_paranoia audio CD library], [libcdio_paranoia not found])
@@ -1604,6 +1615,8 @@ results(cdio_paranoia, [CDIO_PARANOIA])
results(curl,[CURL])
results(despotify,[Despotify])
results(lastfm,[Last.FM])
+results(soundcloud,[Soundcloud])
+printf '\n\t'
results(mms,[MMS])
results(soup, [SOUP])