aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Vollmert <rvollmert@gmx.net>2012-02-27 13:19:45 +0100
committerMax Kellermann <max@duempel.org>2012-03-01 20:11:09 +0100
commit7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122 (patch)
tree1aa8b8a61aba3963f8cf376f4ab9310b0f98d3f2 /configure.ac
parente7ce362d22dd2292a357b167b74dccefc2b7612b (diff)
downloadmpd-7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122.tar.gz
mpd-7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122.tar.xz
mpd-7cef52478dc2d5c5b9d2a75e34e4e57ca5cdb122.zip
A soundcloud playlist plugin.
Requires YAJL to build, and this doesn't include the necessary automake changes. Can be built using ./configure CFLAGS="-I/usr/include/yajl" LIBS="-lyajl" --enable-soundcloud Add the following to your config: playlist_plugin { name "soundcloud" enabled "true" apikey "c4c979fd6f241b5b30431d722af212e8" } Then you can stream from soundcloud using calls like: mpc load soundcloud://track/<track-id> mpc load soundcloud://playlist/<playlist-id> mpc load soundcloud://url/http://soundcloud.com/some/track/or/playlist For the last case, you can leave off the http:// or http://soundcloud.com/ .
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 95bc0183b..0bd8f9aba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,6 +272,11 @@ AC_ARG_ENABLE(despotify,
[enable support for despotify (default: disable)]),,
[enable_despotify=no])
+AC_ARG_ENABLE(soundcloud,
+ AS_HELP_STRING([--enable-soundcloud],
+ [enable support for soundcloud (default: disable)]),,
+ [enable_soundcloud=no])
+
AC_ARG_ENABLE(lame-encoder,
AS_HELP_STRING([--enable-lame-encoder],
[enable the LAME mp3 encoder]),,
@@ -702,6 +707,12 @@ if test x$enable_despotify = xyes; then
fi
AM_CONDITIONAL(ENABLE_DESPOTIFY, test x$enable_despotify = xyes)
+dnl --------------------------------- Soundcloud ------------------------------
+if test x$enable_soundcloud = xyes; then
+ AC_DEFINE(ENABLE_SOUNDCLOUD, 1, [Define when soundcloud is enabled])
+fi
+AM_CONDITIONAL(ENABLE_SOUNDCLOUD, test x$enable_soundcloud = xyes)
+
dnl ---------------------------------- cdio ---------------------------------
MPD_AUTO_PKG(cdio_paranoia, CDIO_PARANOIA, [libcdio_paranoia],
[libcdio_paranoia audio CD library], [libcdio_paranoia not found])
@@ -1604,6 +1615,8 @@ results(cdio_paranoia, [CDIO_PARANOIA])
results(curl,[CURL])
results(despotify,[Despotify])
results(lastfm,[Last.FM])
+results(soundcloud,[Soundcloud])
+printf '\n\t'
results(mms,[MMS])
results(soup, [SOUP])