aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 353f28a4b..964f5c61f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -422,8 +422,17 @@ libstorage_a_SOURCES = \
src/storage/plugins/LocalStorage.cxx src/storage/plugins/LocalStorage.hxx \
src/storage/FileInfo.hxx
+libstorage_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(SMBCLIENT_CFLAGS)
+
STORAGE_LIBS = libstorage.a
+if ENABLE_SMBCLIENT
+libstorage_a_SOURCES += \
+ src/lib/smbclient/Init.cxx src/lib/smbclient/Init.hxx \
+ src/storage/plugins/SmbclientStorage.cxx src/neighbor/plugins/SmbclientStorage.hxx
+endif
+
endif
# neighbor plugins