aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-05 19:23:38 +0100
committerMax Kellermann <max@duempel.org>2014-02-06 07:19:14 +0100
commit957beeb0e943f9bad9d5fae02545cf39bc9fc201 (patch)
treed23e66db0801c6389fd88685bef1717419b3bb5a /Makefile.am
parent522ad4cca656d5efbd5c424eb995ec4784a3179f (diff)
downloadmpd-957beeb0e943f9bad9d5fae02545cf39bc9fc201.tar.gz
mpd-957beeb0e943f9bad9d5fae02545cf39bc9fc201.tar.xz
mpd-957beeb0e943f9bad9d5fae02545cf39bc9fc201.zip
storage/smbclient: Storage implementation using libsmbclient
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 353f28a4b..964f5c61f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -422,8 +422,17 @@ libstorage_a_SOURCES = \
src/storage/plugins/LocalStorage.cxx src/storage/plugins/LocalStorage.hxx \
src/storage/FileInfo.hxx
+libstorage_a_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(SMBCLIENT_CFLAGS)
+
STORAGE_LIBS = libstorage.a
+if ENABLE_SMBCLIENT
+libstorage_a_SOURCES += \
+ src/lib/smbclient/Init.cxx src/lib/smbclient/Init.hxx \
+ src/storage/plugins/SmbclientStorage.cxx src/neighbor/plugins/SmbclientStorage.hxx
+endif
+
endif
# neighbor plugins