aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ede4f6a0d..f39793efb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,22 @@ EXTRA_DIST = $(doc_DATA) autogen.sh \
$(wildcard scripts/*.sh) scripts/mpd.spec \
.gitignore
+
+AM_CFLAGS = -I$(srcdir)/src $(GLIB_CFLAGS)
+AM_LDFLAGS = $(GLIB_LIBS)
+
+
+#
+# Test programs
+#
+
+if ENABLE_TEST
+
+noinst_PROGRAMS =
+
+endif
+
+
sparse-check test:
$(MAKE) -C src $@