aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-11-24 22:18:31 +0100
committerMax Kellermann <max@duempel.org>2014-11-25 13:10:52 +0100
commitfa4d202e71e2ff59583e088d9512424e32d3d761 (patch)
treee0f6966e27a7a1235f882a706c2a5c76db81b823 /configure.ac
parenta8ebfd7a92a48676d753e3ca3ee3175f6ff4d62e (diff)
downloadmpd-fa4d202e71e2ff59583e088d9512424e32d3d761.tar.gz
mpd-fa4d202e71e2ff59583e088d9512424e32d3d761.tar.xz
mpd-fa4d202e71e2ff59583e088d9512424e32d3d761.zip
decoder/mp4v2: remove because of incompatible license
libmp4v2 is licensed under MPL 1.1, which is incompatible with GPLv2. Unfortunately, this means that we must remove the plugin. More information can be found in the Debian bug report: http://bugs.debian.org/767504
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 5a44fa5c8..f8d100331 100644
--- a/configure.ac
+++ b/configure.ac
@@ -496,11 +496,6 @@ AC_ARG_ENABLE(modplug,
[enable modplug decoder plugin]),,
enable_modplug=auto)
-AC_ARG_ENABLE(mp4v2,
- AS_HELP_STRING([--enable-mp4v2],
- [enable libmp4v2 decoder plugin]),,
- enable_mp4v2=auto)
-
AC_ARG_ENABLE(mpc,
AS_HELP_STRING([--enable-mpc],
[disable musepack (MPC) support (default: auto)]),,
@@ -1264,24 +1259,6 @@ if test x$enable_modplug = xyes; then
fi
AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
-dnl -------------------------------- libmp4v2 ---------------------------------
-if test x$enable_aac = xyes; then
- MPD_AUTO_LIB(mp4v2, MP4V2, mp4v2, MP4Create, [-lmp4v2], [],
- [mp4v2], [libmp4v2 not found])
-
- if test x$enable_mp4v2 = xyes; then
- AC_DEFINE(HAVE_MP4V2, 1, [Define to use libmp4v2 for MP4 decoding])
- fi
-else
- if test x$enable_mp4v2 = xyes; then
- AC_MSG_ERROR([MP4V2 requires AAC!])
- fi
-
- enable_mp4v2=no
-fi
-
-AM_CONDITIONAL(HAVE_MP4V2, test x$enable_mp4v2 = xyes)
-
dnl -------------------------------- libopus ----------------------------------
MPD_AUTO_PKG(opus, OPUS, [opus ogg],
[opus decoder plugin], [libopus not found])
@@ -1868,7 +1845,6 @@ printf '\n\t'
results(sndfile, [libsndfile])
results(mikmod, [MikMod])
results(modplug, [MODPLUG])
-results(mp4v2, [MP4V2])
results(mad, [MAD])
results(mpg123, [MPG123])
results(mpc, [Musepack])