aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-13 09:11:22 +0100
committerMax Kellermann <max@duempel.org>2009-02-13 09:11:22 +0100
commitef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525 (patch)
treef2f6337166b55efdf825a6f3df2203a222e90a7e /configure.ac
parentdf9245c2aae7518c813385f7cd721cc17ff27062 (diff)
downloadmpd-ef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525.tar.gz
mpd-ef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525.tar.xz
mpd-ef64449cb65bdb9e0a9c51f5d9f0ef3e220c0525.zip
doc: generate API documentation with doxygen
When configured with --enable-documentation, use doxygen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b742677a2..61c821604 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1077,6 +1077,13 @@ if test x$enable_documentation = xyes; then
fi
AC_SUBST(XMLTO)
+
+ AC_PATH_PROG(DOXYGEN, doxygen)
+ if test x$DOXYGEN = x; then
+ AC_MSG_ERROR([doxygen not found])
+ fi
+
+ AC_SUBST(DOXYGEN)
fi
AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)