aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 20:13:38 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:15 -0700
commited78955f8dec775db3a05c5f1ada6ac50c383b23 (patch)
tree3b9e1ba0fccd2a1435907b9bdbd1869976f4ff0f /configure.ac
parentcab16f8e1ef0bb7a1bedf3f59b17b3947d097c8a (diff)
downloadmpd-ed78955f8dec775db3a05c5f1ada6ac50c383b23.tar.gz
mpd-ed78955f8dec775db3a05c5f1ada6ac50c383b23.tar.xz
mpd-ed78955f8dec775db3a05c5f1ada6ac50c383b23.zip
configure.ac: Move Solaris to Audio Output Plugins (nonstreaming), add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 19 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9b5adf667..30f0da49c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -973,13 +973,7 @@ fi
AM_CONDITIONAL(HAVE_MVP, test x$enable_mvp = xyes)
-enable_shout2="$enable_shout"
-MPD_AUTO_PKG(shout, SHOUT, [shout],
- [shout output plugin], [libshout not found])
-if test x$enable_shout = xyes && test x$enable_shout2 = xauto; then
- enable_shout=auto
-fi
-
+dnl --------------------------------- Solaris ---------------------------------
case "$host_os" in
solaris*)
AC_DEFINE(ENABLE_SOLARIS_OUTPUT, 1, [Define to enable Solaris /dev/audio support])
@@ -1001,6 +995,24 @@ AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
+
+enable_shout2="$enable_shout"
+MPD_AUTO_PKG(shout, SHOUT, [shout],
+ [shout output plugin], [libshout not found])
+if test x$enable_shout = xyes && test x$enable_shout2 = xauto; then
+ enable_shout=auto
+fi
+
+
+
+
+
+
+
+
+
+
+
if test x$enable_mpc = xyes; then
if test "x$mpcdec_libraries" != "x" ; then
MPCDEC_LIBS="-L$mpcdec_libraries"