aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-03-17 18:13:29 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-03-17 18:13:29 +0000
commite7151f941ce4111bcad9c983e3dd747c4f63ab6d (patch)
tree96536203da55bd5d24212fa761e43bcd5629caca /configure.ac
parent9a7636f5bc50fdff56012a38076ec51d3b671711 (diff)
downloadmpd-e7151f941ce4111bcad9c983e3dd747c4f63ab6d.tar.gz
mpd-e7151f941ce4111bcad9c983e3dd747c4f63ab6d.tar.xz
mpd-e7151f941ce4111bcad9c983e3dd747c4f63ab6d.zip
configure script clean ups
git-svn-id: https://svn.musicpd.org/mpd/trunk@268 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac68
1 files changed, 60 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 626831f2c..c3d76ff2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,10 +5,6 @@ AC_PREREQ(2.52)
AC_INIT(mpd, 0.10.1, shank@mercury.chem.pitt.edu)
AM_INIT_AUTOMAKE($PACKAGE_NAME, $PACKAGE_VERSION)
-AC_PROG_CC
-AC_PROG_INSTALL
-AC_PROG_LIBTOOL
-
dnl MAD wants this stuff
AC_SUBST(CCAS)
AC_SUBST(CCASFLAGS)
@@ -22,6 +18,10 @@ AC_SUBST(MP4FF_LIB)
AC_SUBST(MPD_LIBS)
AC_SUBST(MPD_CFLAGS)
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+
MPD_CFLAGS="-Wall"
MPD_LIBS=""
@@ -44,7 +44,7 @@ AC_ARG_WITH(mad,[ --with-mad=PFX Prefix where libmad is installed (optional)]
AC_ARG_WITH(mad-libraries,[ --with-mad-libraries=DIR Directory where libmad library is installed (optional)], mad_libraries="$withval", mad_libraries="")
AC_ARG_WITH(mad-includes,[ --with-mad-includes=DIR Directory where mad header files are installed (optional)], mad_includes="$withval", mad_includes="")
-AC_ARG_WITH(faad2,[ --with-faad2=PFX Prefix where faad2 is installed (optional)], faad_prefix="$withval", faad_prefix="")
+AC_ARG_WITH(faad2,[ --with-faad2=PFX Prefix where faad2 is installed], faad_prefix="$withval", faad_prefix="")
AC_ARG_WITH(faad2-libraries,[ --with-faad-libraries=DIR Directory where faad2 library is installed (optional)], faad_libraries="$withval", faad_libraries="")
AC_ARG_WITH(faad2-includes,[ --with-faad-includes=DIR Directory where faad2 header files are installed (optional)], faad_includes="$withval", faad_includes="")
@@ -224,13 +224,13 @@ if test x$enable_aac = xyes; then
LIBS="$LIBS $MPD_LIBS $FAAD_LIBS"
AC_CHECK_HEADER(faad.h,,enable_aac=no)
if test x$enable_aac = xyes; then
- AC_CHECK_HEADER(mp4.h,,enable_aac=no)
+ AC_CHECK_HEADER(mp4.h,,[enable_aac=no;AC_MSG_WARN(You need mp4v2 installed for AAC/MP4 decoding)])
fi
if test x$enable_aac = xyes; then
- AC_CHECK_LIB(mp4v2, MP4Create,,enable_aac=no)
+ AC_CHECK_LIB(mp4v2, MP4Create,,[enable_aac=no;AC_MSG_WARN(You need mp4v2 installed for AAC/MP4 decoding)])
fi
if test x$enable_aac = xyes; then
- AC_CHECK_LIB(mp4v2, MP4MetadataDelete,,enable_aac=no)
+ AC_CHECK_LIB(mp4v2, MP4MetadataDelete,,[enable_aac=no;AC_MSG_WARN(You need mp4v2 installed for AAC/MP4 decoding)])
fi
if test x$enable_aac = xyes; then
AC_CHECK_LIB(faad, faacDecDecode,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS -DHAVE_FAAD";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
@@ -334,3 +334,55 @@ if test x$enable_audiofile = xyes; then
fi
AC_OUTPUT(src/mp4ff/Makefile doc/Makefile src/Makefile Makefile )
+
+echo ""
+echo "########### MPD CONFIGURATION ############"
+if test x$enable_id3 = xyes; then
+ echo "ID3 tag support ...............enabled"
+ if test x$use_mpd_id3tag = xyes; then
+ echo " using MPD's libid3tag"
+ else
+ echo " not using MPD's libid3tag"
+ fi
+else
+ echo "ID3 tag support ...............disabled"
+fi
+
+if test x$enable_mp3 = xyes; then
+ echo "mp3 support ...................enabled"
+ if test x$use_mpd_mad = xyes; then
+ echo " using MPD's libmad"
+ else
+ echo " not using MPD's libmad"
+ fi
+else
+ echo "mp3 support ...................disabled"
+fi
+
+if test x$enable_ogg = xyes; then
+ echo "Ogg Vorbis support ............enabled"
+else
+ echo "Ogg Vorbis support ............disabled"
+fi
+
+if test x$enable_flac = xyes; then
+ echo "FLAC support ..................enabled"
+else
+ echo "FLAC support ..................disabled"
+fi
+
+if test x$enable_audiofile = xyes; then
+ echo "Wave file support .............enabled"
+else
+ echo "Wave file support .............disabled"
+fi
+
+if test x$enable_aac = xyes; then
+ echo "AAC support ...................enabled"
+else
+ echo "AAC support ...................disabled"
+fi
+
+echo ""
+echo "You are now ready to compile MPD"
+echo "Type \"make\" to compile MPD"