aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-06 07:29:26 +0100
committerMax Kellermann <max@duempel.org>2014-02-06 18:37:27 +0100
commite4322a716c178ffa74bd56542ea6214c4d6845bb (patch)
tree16f81d41faf5a4b5f7e72aedff5497dc3eb8ccfc /configure.ac
parent90886c07603854fe2b46e28890ad88222eea6933 (diff)
downloadmpd-e4322a716c178ffa74bd56542ea6214c4d6845bb.tar.gz
mpd-e4322a716c178ffa74bd56542ea6214c4d6845bb.tar.xz
mpd-e4322a716c178ffa74bd56542ea6214c4d6845bb.zip
input/nfs: new plugin using libnfs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a9b45d3b..79084efc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -310,6 +310,11 @@ AC_ARG_ENABLE(smbclient,
[enable support for libsmbclient (default: auto)]),,
[enable_smbclient=auto])
+AC_ARG_ENABLE(nfs,
+ AS_HELP_STRING([--enable-nfs],
+ [enable support for libnfs (default: auto)]),,
+ [enable_nfs=auto])
+
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging (default: disabled)]),,
@@ -859,6 +864,14 @@ if test x$enable_smbclient = xyes; then
fi
AM_CONDITIONAL(ENABLE_SMBCLIENT, test x$enable_smbclient = xyes)
+dnl ----------------------------------- NFS -----------------------------
+MPD_AUTO_PKG(nfs, NFS, [libnfs],
+ [NFS input plugin], [libnfs not found])
+if test x$enable_nfs = xyes; then
+ AC_DEFINE(ENABLE_NFS, 1, [Define when libnfs is used])
+fi
+AM_CONDITIONAL(ENABLE_NFS, test x$enable_nfs = xyes)
+
dnl --------------------------------- Despotify ---------------------------------
MPD_AUTO_PKG(despotify, DESPOTIFY, [despotify],
[Despotify support], [despotify not found])