aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-12-19 12:59:01 +0100
committerMax Kellermann <max@duempel.org>2013-12-19 12:59:01 +0100
commite30fa7d15e71b9109f4f44c0b388e88b001031af (patch)
tree45ccb582df9e14cca6c7662aae2858a54347cb43 /configure.ac
parentc47630514903da2d84cbc65c71ef1f562be9c1a1 (diff)
downloadmpd-e30fa7d15e71b9109f4f44c0b388e88b001031af.tar.gz
mpd-e30fa7d15e71b9109f4f44c0b388e88b001031af.tar.xz
mpd-e30fa7d15e71b9109f4f44c0b388e88b001031af.zip
configure.ac: add variable $host_is_unix
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index b4bfd0659..b56d4b0e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,7 @@ dnl OS Specific Defaults
dnl ---------------------------------------------------------------------------
AC_CANONICAL_HOST
+host_is_unix=yes
host_is_darwin=no
host_is_solaris=no
host_is_windows=no
@@ -79,6 +80,7 @@ mingw32* | windows*)
AM_CPPFLAGS="$AM_CPPFLAGS -DWINVER=0x0600 -D_WIN32_WINNT=0x0600"
LIBS="$LIBS -lws2_32"
host_is_windows=yes
+ host_is_unix=no
;;
darwin*)
@@ -496,7 +498,7 @@ AC_ARG_ENABLE(twolame-encoder,
AC_ARG_ENABLE(un,
AS_HELP_STRING([--disable-un],
[disable support for clients connecting via unix domain sockets (default: enable)]),,
- [enable_un=yes])
+ [enable_un=$host_is_unix])
AC_ARG_ENABLE(vorbis,
AS_HELP_STRING([--enable-vorbis],
@@ -607,12 +609,6 @@ if test x$enable_tcp = xyes; then
AC_DEFINE(HAVE_TCP, 1, [Define if TCP socket support is enabled])
fi
-case "$host_os" in
-mingw* | windows* | cygwin*)
- enable_un=no
- ;;
-esac
-
if test x$enable_un = xyes; then
AC_DEFINE(HAVE_UN, 1, [Define if unix domain socket support is enabled])
STRUCT_UCRED