aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-09 11:57:47 +0100
committerMax Kellermann <max@duempel.org>2014-01-09 12:19:52 +0100
commitdd82370a80c25322823bade6c9c76845b51eaa71 (patch)
tree53a51c12ba54a647022d6ef0cd82829fa7ef2891 /configure.ac
parentdab052e53d91d7a54d557fb1d8fd762def4e1214 (diff)
downloadmpd-dd82370a80c25322823bade6c9c76845b51eaa71.tar.gz
mpd-dd82370a80c25322823bade6c9c76845b51eaa71.tar.xz
mpd-dd82370a80c25322823bade6c9c76845b51eaa71.zip
playlist/{asx,rss,xspf}: use Expat instead of GLib to parse XML
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58cd5af06..0af602fe4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,11 @@ AC_ARG_ENABLE(libmpdclient,
[enable support for the MPD client]),,
enable_libmpdclient=auto)
+AC_ARG_ENABLE(expat,
+ AS_HELP_STRING([--enable-expat],
+ [enable the expat XML parser]),,
+ enable_expat=auto)
+
AC_ARG_ENABLE(adplug,
AS_HELP_STRING([--enable-adplug],
[enable the AdPlug decoder plugin (default: auto)]),,
@@ -639,6 +644,15 @@ fi
AM_CONDITIONAL(HAVE_LIBMPDCLIENT, test x$enable_libmpdclient = xyes)
+dnl -------------------------------- expat --------------------------------
+MPD_AUTO_PKG(expat, EXPAT, [expat],
+ [expat XML parser], [expat not found])
+if test x$enable_expat = xyes; then
+ AC_DEFINE(HAVE_EXPAT, 1, [Define to use the expat XML parser])
+fi
+
+AM_CONDITIONAL(HAVE_EXPAT, test x$enable_expat = xyes)
+
dnl --------------------------------- inotify ---------------------------------
AC_CHECK_FUNCS(inotify_init inotify_init1)