aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:30:56 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:32 -0700
commitd73291959b529f124ab9e091f513ba4d801def81 (patch)
treec0840a0165acb17170e78370abae1f26d6ff4c55 /configure.ac
parent01a675eb5f0fef01a39b4ed874ca1bc0dd33ce21 (diff)
downloadmpd-d73291959b529f124ab9e091f513ba4d801def81.tar.gz
mpd-d73291959b529f124ab9e091f513ba4d801def81.tar.xz
mpd-d73291959b529f124ab9e091f513ba4d801def81.zip
configure.ac: Organize all added CFLAGs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 19 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index ac289bcfd..aed24ae5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1364,25 +1364,6 @@ fi
AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
-dnl
-dnl build options
-dnl
-
-
-if test "x$enable_werror" = xyes; then
- AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
-fi
-
-#if test "x$enable_debug" = xno; then
- # don't set NDEBUG for now, until MPD is stable
- #AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
-#fi
-
-if test "x$enable_gprof" = xyes; then
- MPD_CFLAGS="$MPD_CFLAGS -pg"
- MPD_LIBS="$MPD_LIBS -pg"
-fi
-
dnl ---------------------------------------------------------------------------
dnl test suite
dnl ---------------------------------------------------------------------------
@@ -1391,6 +1372,14 @@ AM_CONDITIONAL(ENABLE_TEST, test "x$enable_test" = xyes)
dnl ---------------------------------------------------------------------------
dnl CFLAGS
dnl ---------------------------------------------------------------------------
+
+dnl ---------------------------------- debug ----------------------------------
+#if test "x$enable_debug" = xno; then
+ # don't set NDEBUG for now, until MPD is stable
+ #AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
+#fi
+
+dnl ----------------------------------- GCC -----------------------------------
if test x$GCC = xyes
then
MPD_CHECK_FLAG([-Wall])
@@ -1405,6 +1394,17 @@ then
MPD_CHECK_FLAG([-pedantic])
fi
+dnl ------------------------------ gprof profiler -----------------------------
+if test "x$enable_gprof" = xyes; then
+ MPD_CFLAGS="$MPD_CFLAGS -pg"
+ MPD_LIBS="$MPD_LIBS -pg"
+fi
+
+dnl ---------------------------- warnings as errors ---------------------------
+if test "x$enable_werror" = xyes; then
+ AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
+fi
+
dnl ---------------------------------------------------------------------------
dnl Pretty-Print Results
dnl ---------------------------------------------------------------------------