aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-02-21 10:27:07 +0100
committerMax Kellermann <max@duempel.org>2014-02-21 10:27:07 +0100
commitd25ef7eea4aff44c2e3939ccb803ddb933135194 (patch)
treee04755001d1b125480c14783907f3806a2573422 /configure.ac
parent30a82076ba50a21c4df5fe4c46c8fc2ed25a7486 (diff)
downloadmpd-d25ef7eea4aff44c2e3939ccb803ddb933135194.tar.gz
mpd-d25ef7eea4aff44c2e3939ccb803ddb933135194.tar.xz
mpd-d25ef7eea4aff44c2e3939ccb803ddb933135194.zip
configure.ac: detect Android cross-build
Define "ANDROID" if the host operating system is Android.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ac6d2a9d..c0aa04c58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,7 @@ AC_CANONICAL_HOST
host_is_unix=yes
host_is_linux=no
+host_is_android=no
host_is_darwin=no
host_is_solaris=no
host_is_windows=no
@@ -79,6 +80,13 @@ host_is_windows=no
linux_auto=no
case "$host_os" in
+linux-android*)
+ host_is_android=yes
+ host_is_linux=yes
+ linux_auto=auto
+ AM_CPPFLAGS="$AM_CPPFLAGS -DANDROID"
+ ;;
+
linux*)
host_is_linux=yes
linux_auto=auto
@@ -104,6 +112,8 @@ solaris*)
host_is_solaris=yes
;;
esac
+
+AM_CONDITIONAL([ANDROID], [test x$host_is_android = xyes])
AM_CONDITIONAL([HAVE_WINDOWS], [test x$host_is_windows = xyes])
if test -z "$prefix" || test "x$prefix" = xNONE; then