aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-04 15:25:57 +0100
committerMax Kellermann <max@duempel.org>2009-02-04 15:25:57 +0100
commitcd98a72ca6dea49ccf85ed345830e5d2bd8e4ba1 (patch)
treed08c0500f12ea14b03cd6e0fa5d9c2cf7b2921b5 /configure.ac
parent824d299eb13e2fc4d03f5c4974a9c4f6511fd284 (diff)
downloadmpd-cd98a72ca6dea49ccf85ed345830e5d2bd8e4ba1.tar.gz
mpd-cd98a72ca6dea49ccf85ed345830e5d2bd8e4ba1.tar.xz
mpd-cd98a72ca6dea49ccf85ed345830e5d2bd8e4ba1.zip
configure.ac: make DocBook processing optional
Disable the HTML documentation generator by default. Most users will pick it from the web site.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 12 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6f6711792..187d2bd59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1006,16 +1006,21 @@ dnl
dnl Documentation
dnl
-AC_MSG_CHECKING([for xmlto (DocBook processing)])
-AC_PATH_PROG(XMLTO, xmlto)
-if test x$XMLTO != x; then
+AC_ARG_ENABLE(documentation,
+ AS_HELP_STRING([--enable-documentation],
+ [build documentation (default: disable)]),,
+ [enable_documentation=no])
+
+if test x$enable_documentation = xyes; then
+ AC_PATH_PROG(XMLTO, xmlto)
+ if test x$XMLTO = x; then
+ AC_MSG_ERROR([xmlto not found])
+ fi
+
AC_SUBST(XMLTO)
- AC_MSG_RESULT($XMLTO)
-else
- AC_MSG_RESULT(no)
fi
-AM_CONDITIONAL(HAVE_XMLTO, test x$XMLTO != x)
+AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
dnl