aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-29 21:42:10 +0100
committerMax Kellermann <max@duempel.org>2009-01-29 21:42:10 +0100
commitcaa4d28f044d70012cd113f324e6500c0b57d491 (patch)
tree5f904a7668b602480c660d04e4cbc3b075b4be99 /configure.ac
parent36ca114629d8e9bef2faff3716ccdf8f7641fd10 (diff)
downloadmpd-caa4d28f044d70012cd113f324e6500c0b57d491.tar.gz
mpd-caa4d28f044d70012cd113f324e6500c0b57d491.tar.xz
mpd-caa4d28f044d70012cd113f324e6500c0b57d491.zip
added support for the MMS protocol
This patch implements the MMS protocol, by using libmms. It is quite experimental: it does not support seeking yet, and it is currently using synchronous I/O, which causes MPD to hang while waiting for the server.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff4c1457c..0461b839c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,18 @@ if test x$enable_curl = xyes; then
fi
AM_CONDITIONAL(HAVE_CURL, test x$enable_curl = xyes)
+AC_ARG_ENABLE(mms,
+ AS_HELP_STRING([--enable-mms],
+ [enable the MMS protocol with libmms (default: disable)]),,
+ [enable_mms=yes])
+
+if test x$enable_mms = xyes; then
+ PKG_CHECK_MODULES(MMS, [libmms],
+ AC_DEFINE(ENABLE_MMS, 1, [Define when libmms is used for the MMS protocol]),
+ AC_MSG_ERROR([libmms not found]))
+fi
+AM_CONDITIONAL(ENABLE_MMS, test x$enable_mms = xyes)
+
dnl
dnl archive plugins
@@ -1318,6 +1330,12 @@ else
echo " HTTP streaming (libcurl) ......disabled"
fi
+if test x$enable_mms != xno; then
+ echo " MMS streaming (libmms) ........enabled"
+else
+ echo " MMS streaming (libmms) ........disabled"
+fi
+
echo ""
echo "##########################################"
echo ""