aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-07-30 22:26:24 +0200
committerMax Kellermann <max@duempel.org>2014-08-06 16:35:10 +0200
commitc9a71a7176f13cbd86c8270c523c0e506b2ab424 (patch)
tree1bc505fe58a10f2ddcd9fc4fa6671919eeeeba4d /configure.ac
parent7ed8833fd567da2b0583365b1790ff61cd10cfd5 (diff)
downloadmpd-c9a71a7176f13cbd86c8270c523c0e506b2ab424.tar.gz
mpd-c9a71a7176f13cbd86c8270c523c0e506b2ab424.tar.xz
mpd-c9a71a7176f13cbd86c8270c523c0e506b2ab424.zip
fs/GzipOutputStream: new class wrapping zlib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dbbb5a5ac..a5b875229 100644
--- a/configure.ac
+++ b/configure.ac
@@ -329,6 +329,11 @@ AC_ARG_ENABLE(audiofile,
[enable audiofile support (WAV and others)]),,
enable_audiofile=auto)
+AC_ARG_ENABLE(zlib,
+ AS_HELP_STRING([--enable-zlib],
+ [enable zlib support (default: auto)]),,
+ enable_zlib=auto)
+
AC_ARG_ENABLE(bzip2,
AS_HELP_STRING([--enable-bzip2],
[enable bzip2 archive support (default: auto)]),,
@@ -1031,6 +1036,16 @@ fi
AM_CONDITIONAL(ENABLE_ISO9660_TEST, test x$MKISOFS != xno)
+dnl ---------------------------------- zlib ---------------------------------
+
+MPD_AUTO_PKG(zlib, ZLIB, [zlib],
+ [zlib support], [zlib not found])
+
+AM_CONDITIONAL(HAVE_ZLIB, test x$enable_zlib = xyes)
+if test x$enable_zlib = xyes; then
+ AC_DEFINE(HAVE_ZLIB, 1, [Define to enable zlib support])
+fi
+
dnl ---------------------------------- libbz2 ---------------------------------
MPD_AUTO_LIB(bzip2, BZ2, bz2, BZ2_bzDecompressInit, [-lbz2], [],