aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-12-15 20:29:44 +0100
committerMax Kellermann <max@duempel.org>2009-12-15 20:29:44 +0100
commitc959148ed1aae9b31a649a08f5dd8a51ef128942 (patch)
treea7b678b2a5989cd2499cf203eb1c3342554436c4 /configure.ac
parent530e480748854f43819c3dd1dbe6418c343b4f64 (diff)
downloadmpd-c959148ed1aae9b31a649a08f5dd8a51ef128942.tar.gz
mpd-c959148ed1aae9b31a649a08f5dd8a51ef128942.tar.xz
mpd-c959148ed1aae9b31a649a08f5dd8a51ef128942.zip
archive/zip: renamed plugin to "zzip"
This plugin is based on libzzip.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 93f062068..9f0219127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,18 +355,18 @@ if test x$enable_bzip2 = xyes; then
AC_DEFINE(HAVE_BZ2, 1, [Define to have bz2 archive support])
fi
-dnl zip
-AC_ARG_ENABLE(zip,
- AS_HELP_STRING([--enable-zip],
+dnl zzip
+AC_ARG_ENABLE(zzip,
+ AS_HELP_STRING([--enable-zzip],
[enable zip archive support (default: disabled)]),,
- enable_zip=no)
+ enable_zzip=no)
-MPD_AUTO_PKG(zip, ZZIP, [zziplib >= 0.13],
+MPD_AUTO_PKG(zzip, ZZIP, [zziplib >= 0.13],
[libzzip archive library], [libzzip not found])
-AM_CONDITIONAL(HAVE_ZIP, test x$enable_zip = xyes)
-if test x$enable_zip = xyes; then
- AC_DEFINE(HAVE_ZIP, 1, [Define to have zip archive support])
+AM_CONDITIONAL(HAVE_ZZIP, test x$enable_zzip = xyes)
+if test x$enable_zzip = xyes; then
+ AC_DEFINE(HAVE_ZZIP, 1, [Define to have zip archive support])
fi
dnl iso9660
@@ -386,7 +386,7 @@ fi
dnl archive API
if
test x$enable_bzip2 = xyes ||
- test x$enable_zip = xyes ||
+ test x$enable_zzip = xyes ||
test x$enable_iso9660 = xyes; then
enable_archive=yes
AC_DEFINE(ENABLE_ARCHIVE, 1, [The archive API is available])
@@ -1625,7 +1625,7 @@ else
echo " ISO 9660 archives support .....disabled"
fi
-if test x$enable_zip = xyes; then
+if test x$enable_zzip = xyes; then
echo " ZIP archives support ..........enabled"
else
echo " ZIP archives support ..........disabled"