aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-28 19:48:53 +0100
committerMax Kellermann <max@duempel.org>2008-12-28 19:48:53 +0100
commitc01aa53e6a972cd83e866b6b2e390449f2a59658 (patch)
tree822555fad1f64663906bb8b54e35b71393d15b6d /configure.ac
parentc6cb611065ab1260ff07b939a9fafa4027fcc5c8 (diff)
downloadmpd-c01aa53e6a972cd83e866b6b2e390449f2a59658.tar.gz
mpd-c01aa53e6a972cd83e866b6b2e390449f2a59658.tar.xz
mpd-c01aa53e6a972cd83e866b6b2e390449f2a59658.zip
log: support syslog()
Allow logging to syslog if log_file is configured to "syslog".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37085d475..864eb1184 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,21 @@ fi
dnl
+dnl libc features
+dnl
+
+AC_CHECK_FUNCS(syslog)
+if test $ac_cv_func_syslog = no; then
+ # syslog is not in the default libraries. See if it's in some other.
+ for lib in bsd socket inet; do
+ AC_CHECK_LIB($lib, syslog,
+ [AC_DEFINE(HAVE_SYSLOG)
+ LIBS="$LIBS -l$lib"; break])
+ done
+fi
+
+
+dnl
dnl build options
dnl