aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-25 16:46:07 +0100
committerMax Kellermann <max@duempel.org>2009-02-25 16:46:07 +0100
commitbdb3129f18cc42dce09984108801937512667209 (patch)
tree5109958f18ef110a8f27d9f38ccdd274e76b7fca /configure.ac
parent6fdaa49668e126938c187cabfd78a818a3f68de9 (diff)
downloadmpd-bdb3129f18cc42dce09984108801937512667209.tar.gz
mpd-bdb3129f18cc42dce09984108801937512667209.tar.xz
mpd-bdb3129f18cc42dce09984108801937512667209.zip
configure.ac: declare AM_CFLAGS
Moved generic compiler options to AM_CFLAGS. MPD_CFLAGS/MPD_LIBS will hopefully fade away one day, in favor of more fine-grained variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ddebb0bdc..653bea29d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,8 @@ dnl
dnl declare variables
dnl
+AC_SUBST(AM_CFLAGS,"")
+
AC_SUBST(MPD_LIBS)
AC_SUBST(MPD_CFLAGS)
MPD_LIBS=""
@@ -1105,7 +1107,7 @@ AC_ARG_ENABLE(werror,
ENABLE_WERROR=no)
if test "x$ENABLE_WERROR" = xyes; then
- MPD_CFLAGS="$MPD_CFLAGS -Werror -pedantic-errors"
+ AM_CFLAGS="$AM_CFLAGS -Werror -pedantic-errors"
fi
AC_ARG_ENABLE(debug,
@@ -1116,7 +1118,7 @@ AC_ARG_ENABLE(debug,
#if test "x$ENABLE_DEBUG" = xno; then
# don't set NDEBUG for now, until MPD is stable
- #MPD_CFLAGS="$MPD_CFLAGS -DNDEBUG"
+ #AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
#fi
AC_ARG_ENABLE(gprof,