aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-11-29 12:30:29 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-11-29 12:30:29 +0600
commitb9035d3e0a3a413700ea87cd539b075d4f5aa764 (patch)
treeb69a86f8f835be7a1989430756c2f2d99999e9ba /configure.ac
parente504913b0f118ddaa8e14ae9f8325c3dd5a339a6 (diff)
downloadmpd-b9035d3e0a3a413700ea87cd539b075d4f5aa764.tar.gz
mpd-b9035d3e0a3a413700ea87cd539b075d4f5aa764.tar.xz
mpd-b9035d3e0a3a413700ea87cd539b075d4f5aa764.zip
configure.ac: code style improvements
Rename HAVE_WINDOWS to host_is_windows for consistency. Use 'yes' as true value instead of '1' for this variable. Use test on this variable instead of case where applicable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 10 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 4ba2b2d3b..db35fc0bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,7 @@ dnl ---------------------------------------------------------------------------
AC_CANONICAL_HOST
host_is_darwin=no
+host_is_windows=no
case "$host_os" in
mingw32* | windows*)
@@ -76,14 +77,14 @@ mingw32* | windows*)
AM_CPPFLAGS="$AM_CPPFLAGS -DWIN32_LEAN_AND_MEAN"
AM_CPPFLAGS="$AM_CPPFLAGS -DWINVER=0x0600 -D_WIN32_WINNT=0x0600"
LIBS="$LIBS -lws2_32"
- HAVE_WINDOWS=1
+ host_is_windows=yes
;;
darwin*)
host_is_darwin=yes
;;
esac
-AM_CONDITIONAL([HAVE_WINDOWS], [test x$HAVE_WINDOWS = x1])
+AM_CONDITIONAL([HAVE_WINDOWS], [test x$host_is_windows = xyes])
if test -z "$prefix" || test "x$prefix" = xNONE; then
local_lib=
@@ -1443,17 +1444,13 @@ AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
dnl --------------------------------- WinMM ---------------------------------
-case "$host_os" in
- mingw32* | windows*)
- AC_DEFINE(ENABLE_WINMM_OUTPUT, 1, [Define to enable WinMM support])
- enable_winmm_output=yes
- LIBS="$LIBS -lwinmm"
- ;;
-
- *)
- enable_winmm_output=no
- ;;
-esac
+if test "x$host_is_windows" = xyes; then
+ AC_DEFINE(ENABLE_WINMM_OUTPUT, 1, [Define to enable WinMM support])
+ enable_winmm_output=yes
+ LIBS="$LIBS -lwinmm"
+else
+ enable_winmm_output=no
+fi
AM_CONDITIONAL(ENABLE_WINMM_OUTPUT, test x$enable_winmm_output = xyes)